Thermofisher.com is compatible with the browsers below. If you are using an older version of one of these browsers, you will not receive the full thermofisher.com experience and, in some cases, will not fully benefit from newer tools and features.

The following browser versions are supported:

  • Microsoft Internet Explorer 10 or above
  • Mozilla Firefox 33 or above
  • Google Chrome 39 or above
  • Safari 7 or above

If you are using a browser that is not supported, we recommend you upgrade to the latest version of Internet Explorer, Mozilla Firefox, Chrome, or Safari by following the appropriate link below.

Credit card payment security standards

In addition, the Payment Card Industry (PCI) Security Standards Council LLC dictates how credit card information can be transmitted through the internet to ensure your information is safe and secure. To maintain compliance, if you are using a non-secure web browser, you may not be able to use a credit card to make a purchase on thermofisher.com.

To avoid this situation, you will either need to upgrade your browser to a supported version, or change your browser’s Transport Layer Security (TLS) protocol such that it meets current encryption standards designed to protect the privacy of information communicated over the internet. This will be TLS 2.1 or greater.  

If you have updated your browser and you cannot place an order via credit card because the security warning persists, we recommend you contact your web administration team to review your web browser protocol. Below are some additional useful instructions to update your browser’s TLS version, if required:

Microsoft Internet Explorer

  • From the menu bar, click Tools >  Internet Options > Advanced tab
  • Scroll down to Security category, manually check the option box for Use TLS 1.1 and Use TLS 1.2, then OK
  • Restart Internet Explorer

Google Chrome

  • Open Google Chrome
  • Click Alt F and select Settings
  • Scroll down and select Show advanced settings...
  • Scroll down to the Network section and click on Change proxy settings...
  • Select the Advanced tab
  • Scroll down to Security category, manually check the option box for Use TLS 1.1 and Use TLS 1.2
  • Restart Google Chrome

Mozilla Firefox

  • Open Firefox
  • In the address bar, type about:config and press Enter
  • In the Search field, enter tls. Find and double-click the entry for security.tls.version.min
  • Set the integer value to 3 to force protocol of TLS 1.3, then OK
  • Restart Mozilla Firefox

 Apple Safari

  • If you are using Safari version 7 or greater, TLS 1.2 is enabled

Our site supports these browsers:

  • Mozilla Firefox (most recent version)
  • Google Chrome (most recent version)